Back to overview
Degraded
Connectivity issues affecting all services
Mar 13, 2026 at 2:17pm UTC
Affected services
Websites
Editor
Landing pages
Resolved
Mar 13, 2026 at 3:28pm UTC
All services are fully operational again.
We are also actively implementing improvements to prevent the situation from reoccurring.
Affected services
Created
Mar 13, 2026 at 2:17pm UTC
We're experiencing intermittent connectivity problems across most services and customer websites. We have identified the cause to be a DDoS attack, which we are mitigating as we speak.
Affected services